Lenovo T400 benötigt beim Starten zwei mal das Boot-Passwort

Bis vor Kurzem musste ich jeweils zwei mal das Festplattenkennwort angeben beim Starten des Laptops. Bios updaten hat nichts gebracht (ja eigentlich den Fehlr sogar erst erzeugt) und die Einstellungen wiederherstellen und diverse Dinge (wie Security-Chip, etc) zurücksetzen haben nicht geholfen. Nach einigem Googlen und rumprobieren dann die Lösung:
Ein Bios-Update hatte die “Intel Trusted Execution Technology” quasi aktiviert, bzw. überhaupt erst möglich gemacht. Die Funktion ansich war vorher schon vorhanden, liess sich im Bios jedoch nie aktivieren. Mit dem Update wurde die Funktion nicht nur ermöglicht, sondern auch gleich aktiviert. Wieso man das Boot- bzw. Festplattenkennwort zwei mal angeben muss wenn “TXT” aktiviert ist, fand ich nicht heraus. Jedenfalls kann man die Option deaktivieren und muss sich dannach nur noch ein mal pro Systemstart einloggen.

Windows 7 / Vista und Personal E-mail Certificates

Thawte bietet kostenlose Zertifikate an um Emails zu Signieren. Die Idee gefiel mir und ich hab es gleich mal ausprobiert.
-> Anmelden, Zertifikat erstellen, warten bis es fertig ausgestellt wird, dann runterladen installieren und Emails signieren.
So zumindest hatte ich mir das vorgestellt. Ich verwendete Firefox beim Erstellen und bis zum Runterladen des Zertifikats ging auch alles gut. Nur installieren lies es sich nicht. Es fehlte der private Schlüssel. Nach langem Suchen fand ich dann heraus, dass ich das ganze mit dem Internet Explorer machen muss, da sonst der private Schlüssel nicht in den Zertifikatsspeicher von Windows kommt.
Also. Altes Zertifikat widerrufen, neues mit dem IE erstellen. Tja, einfacher gesagt als getan. Thawte mag den IE8 nicht! Wenn man den IE8 in den “Kompatibilitätsmodus” wechselt, verhält er sich beinahe wie ein IE7. Auch der “Kompatibilitäsmodus” hilft nur bedingt, denn Windows 7/Vista unterstützen einige Funktionen nicht und so kann der IE die Zertifikate nicht installieren.
Schlussendlich habe ich dann einen anderen PC (bzw. VMWare) mit Windows XP verwendet. Da funktionierte das Ganze dann mit IE8 (und dem Kompatibilitätsmodus) wunderbar. Das Zertifikat konnte Installiert und dann wieder Exportiert werden. Beides inklusive privatem Key.
Die Exportierte Version lies sich dann ohne weiteres in Windows 7 installieren (eigentlich importieren) und Outlook 2007 akzeptierte das Zertifikat ohne wenn und aber.